VW T4 Forum - VW T5 Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Hi, I have seen some posts on this in the past but not really clear on what people done to sole these issues.
I have a 2007 T5 174. Recently the ABS & traction control & handbrake light came on, along with an audio warning on start up.
A few days later, the speedo stopped working, the fuel gauge is constantly going up and down, the trip meter isn't working also the traction control switch isn't working! Its worth noting that the van is driving perfectly and the ABS is definitely working as I tried it on wet grass and couldn't lock the wheels!
Similar posts have suggested a range of causes; abs sensor failure, abs pump failure, alternator faulty. An indi VW garage are going to look at it on Saturday and have suggested the most possible cause is a dashboard connection fault. I did read someone else's post who had similar symptoms and it turned out to be a burnt multi plug connector in the back of the dash, which was a relatively easy fix but a bitch to get at!
I would welcome any comments that might help me along the way to getting to the cause.
I will add that I also have a leisure battery fitted and a split charging system, I have power from the leisure battery going into the fuse-box to power the radio, interior lights and cigarette lighter socket. But this has all been working perfectly for 2 and a half years so I'd be surprised if its connected.
 

·
Registered
Joined
·
11 Posts
Hi Farmer,
Ive had this recently on my 06 plate 4 motion. It took a while to find i can tell you !!! VW garage found no error codes or problems so said it needed to be looked at by an Auto Electrician !!!

After an hours work they concluded the ABS pump ECU was to blame and when £1400 inc vat was mentioned i searched the net for help.

They recommended sending it to one company who repaired ECUs but they returned it saying it was beyond repair.

I found a company called ECU Testing, very helpful and friendly. The unit was there for over a week as they were very busy but im happy to say it WAS repairable and came with a lifetime warranty (for the repair) all in for £260 so much better than buying new!!

Having the same unit meant no issues with the main ECU etc so all good.

They charge a small fee to check them first so if you have any questions i suggest you send it in.

This is a very common fault in VWs im afraid, just search google for ABS faults !

Hope this helps
 

·
Registered
Joined
·
4 Posts
Farmer Giles, did you find out what the problem/solution was? Was is as Hojo suggested or something else?

My 07 plate mapped to 174 did this to me today (ABS and ESP lights on, parking brake light flashing. No speedo, erratic fluctuating fuel gauge, and multiple beeps and warnings).

In a bit of a panic coz its been running great with absolutely no problems sice I got it, now this!
 

·
Registered
Joined
·
1,096 Posts
I had exactly this happen to me today!!!!!!!! Its booked in for a respray in a few weeks and ive spent loads so please say this isnt gunna be big money!!!!!!!

I have speedo and trip fault, eratic fuel indicator, three beep handbrake flashing sign and abs and asr along with engine managment light so prity much everything!
Runs fine tho!
Help help help help help!!!!!!!!!!!!
 

·
Registered
Joined
·
407 Posts
I had exactly this happen to me today!!!!!!!! Its booked in for a respray in a few weeks and ive spent loads so please say this isnt gunna be big money!!!!!!!

I have speedo and trip fault, eratic fuel indicator, three beep handbrake flashing sign and abs and asr along with engine managment light so prity much everything!
Runs fine tho!
Help help help help help!!!!!!!!!!!!
I had this last year and I needlessly changed the ABS unit as it didn't solve it unfortunately. I took mine to Auto-Electrics in Cosham...(are you near them?) and after several attempts we narrowed it down to the wiring that comes out of the ignition barrell and goes behind the dash. It could be a number of things though but definitely electrical. mine kept binging and bonging too so drove me nuts!

good luck!.....T:

PS...... I still have an ABS unit in the shed if its the same type and you need to try one.
 

·
Registered
Joined
·
62 Posts
I had this last year and I needlessly changed the ABS unit as it didn't solve it unfortunately. I took mine to Auto-Electrics in Cosham...(are you near them?) and after several attempts we narrowed it down to the wiring that comes out of the ignition barrell and goes behind the dash. It could be a number of things though but definitely electrical. mine kept binging and bonging too so drove me nuts!

good luck!.....T:

PS...... I still have an ABS unit in the shed if its the same type and you need to try one.
looking for one mate you selling it ?
 

·
Registered
Joined
·
771 Posts
Hi have you found the problem yet cos mine has the same problem its an 07 1.9 lwb and has been running great but abs and traction control lights started flashing amber then the beeping noise ?
 

·
Registered
Joined
·
771 Posts
Hi well been down mates garage today and decided to have the abs pump and module tested and repaired sending it off tomorrow so no van for a week :(
 

·
Registered
Joined
·
771 Posts
Van all sorted now it the ecu and sent it off to ecu testing .com and they repaired it so all good now .My problem started with traction control light and abs light started to flash on and off then got worse and stayed on with the brake warning red light then speedo stopped woking and fuel gauge kept bouncing from empty to full in the end it would not start and was unable to get any fault codes.So sent it off the ecu and pump to get tested (if its not faulty there is a £40 charge and they send it back ) but it was faulty and repairable (some are not ) there is also a lifetime warranty on unit as long as you own van .This seems like a common fault my van is a 07 1.9 T5 LWB .
 

·
Registered
Joined
·
1,709 Posts
:(:(:( I HATE my van. There's ALWAYS something going wrong with the electrics somewhere :(:(:(

(As of 2pm today I now have the ABS/ASR lights on and flashing handbrake warning light on - and no spare £££)
 

·
Registered
Joined
·
1,096 Posts
Mine was not repairable and yes I just spent £1700 on a new abs module!!!!!!! Warranty coverd £1000 of it so as a warning its not always a loose wire and not all abs pumps can be repaired as mine was fryed!!!!!

Good luck hope ures is cheaper than mine:( mind you I'm glad of the piece of mind now!
 

·
Registered
Joined
·
8 Posts
Could you tell me the name of the place you got it repaired mate?My van was in an accident and alot of the wiring was damaged.Its now been repaired but I'm having the same problem so I'm unsure weather it's the ecu or wiring.Id like to get the ecu tested but there doesn't seem to be anyone here in Ireland tat can do it properly
 

·
Registered
Joined
·
436 Posts
Just had a T5 in and condemed the A.B.S pump E.C.U (available seperatley from complete unit) its coming back when customer has saved some pennies up !
 

·
Registered
Joined
·
3,350 Posts
feel you pain,had a new abs ecu the other month

after reading a lot about these pesky things on ALL vw foums the majority seem to fit in with being jump started within a month or two "mine was" :ILU:
 
1 - 20 of 38 Posts
Top