VW T4 Forum - VW T5 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
My battery stopped charging and the light on the dash just didn't come on full stop. If I charged it up with a battery charger it's be fine again for a few days til it gradually went flat again. Took it to a garage, put a tester on it which said 'not charging' - alternator fault. So I've replaced the alternator but the battery light on the dash still doesn't come on at all. I've yet to see if the new alternator is doing it's job.

Is it possible that the battery light/led on the dash is knackered?
 

·
Registered
Joined
·
438 Posts
You need a voltmeter. First, with the engine off, measure the voltage across the battery terminals. Then with the engine running, and revved up to 2000rpm or more, measure again. If the voltage across the battery has gone up, all is probably well.

I'm not familiar enough with the charging circuit on a T4 to diagnose it without looking at wiring diagrams - but I did once have a fault on my motorbike where only the diodes to the charge indicator light had failed - and it really was charging ok - though I suspect that's rare.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #5 ·
Nope, no split-charging system.

I''ve had a volt meter across the terminals on the battery, it goes up when you start and rev the engine. That would indicate to me that the new alternator is performing correctly. The lack of a light on the dash is just a bit of a puzzle.
 

·
Registered
Joined
·
32 Posts
Hello all
First post so be gentle.
I have had tha same problem. Starter motor packed up, brushes went. So had it recond. Put back on wire going to same terminals as they came off. She started up first time. ( usally takes a an couple of seconds befor firing) not now first turn and she away :). The problem was the battery light stayed on???????.

Checked all wires on starter, ok. Even checked blue wire to alt, fine. head scratching time.

booked it in at auto elecy for this morning. Anyway fault found to be that the feed wires to the starter were the wrong way round.
Strange as they most definatly went back on the way they came off.

might also be the reason why the battery light would only go out after I reved it after starting.

Thanks for reading.

Stu
 

·
Registered
Joined
·
2,354 Posts
mickle141 when you first turn key does the battery light come on as it should ,
 
1 - 7 of 7 Posts
Top