VW T4 Forum - VW T5 Forum banner

1 - 20 of 66 Posts

·
Registered
Joined
·
274 Posts
Discussion Starter #1
I wondered if someone might be able to help with the following as I seem to have run out of ideas:

Usual flashing light bringing up error code 16955 (Brake Light Switch)

I have stripped switch and cleaned up all connections (twice!) as per excellent write up on here A:

Swapped both bulbs (brake lights have always worked fine)

Checked brake fluid level (fine)

Checked all fuses (fine)

Cleared fault code and still keeps coming back!

I bought a new switch from the dealer and they sold me part number S1C0945511ARDW which is the green switch that looks very different to original one. As they have updated switch I assumed this was the correct one but when I installed it the glow plug light doesnt come on when the ignition is turned and the van wont start, questioned dealer and he says its the right switch?

Anybody got any other ideas / experiences of what could be causing the error code? Apologies if this is answered somewhere but I think I have read every post on this and not found any other causes.

Can you get patterned 4 pin switches as all the ones I have found at factors are only 2 pin?

Thanks :)
 

·
Registered
Joined
·
10,602 Posts
You have to have the right switch. Do you know about "setting" the switch to the right length?
 

·
Registered
Joined
·
193 Posts
If you have vag com, you can go in measure value blocks and check the switch operation. (can't remember channel at the moment)

If thats working, possibly broken wire.?
 

·
Registered
Joined
·
274 Posts
Discussion Starter #5
Cheers for the replies guys, I have set the switch to the right length (old one does not have a locking mech).
The switch works brakes, does the rev slow thing (cruise control test). Think I will try and find a 4 pin switch at a breakers and if that doesn't work start trying to find faults on wires
 

·
Registered
Joined
·
265 Posts
I changed my 4 pin switch recently. I asked for a new switch at GSF. They gave me a green one that looked nothing like the one I'd taken out but they assured me it was the right one and would work.
It didn't work.
I took it back and spoke to someone else, they told me there were 2 different types. He swapped it for the other type which just so happened to look exactly the same as the one I took out - worked straight away! And it was a couple of quid cheaper...
 

·
Premium Member
Joined
·
974 Posts
I had the 'Brake Light Switch(F) Implausable Signal' error code too.

The green switch doens't work as a replacement for the all black one (im my experience), the all black one is still available from dealers and is an easy repair when you get it.
T:
 

·
Registered
Joined
·
274 Posts
Discussion Starter #8
I thought that they had sold me the wrong switch but the guy at the counter was having none of it, I've been back to swap it and they wouldn't because the computer said it was the right one.

Anyone want a green switch? I'm off to GSF!
 

·
Registered
Joined
·
1,573 Posts
I had exactly the same problem as you mate. The black switch is still available. Anyone who thinks that it has been superceeded by the green one is mistaken.
 

·
Registered
Joined
·
772 Posts
mine recently failed and the green switch is for a t5 though they say it is the t4 replacement , the part no. for mine is a lupo brake switch and was avaliable from tps for a tenner but the green one is way to short dispite what the damn computer says :bhd:bhd
 

·
Registered
Joined
·
95 Posts
had similar problem last year . usual codes coming up re brake switch etc. vw main dealer couldn't get it sorted.
suffered it for about a month untill one morning i noticed reversing lights weren't working, checked and replaced fuse, not only did the reversing work but the warning light went out. hasn't come back on since. might be worth checking.
 

·
Registered
Joined
·
274 Posts
Discussion Starter #14
had similar problem last year . usual codes coming up re brake switch etc. vw main dealer couldn't get it sorted.
suffered it for about a month untill one morning i noticed reversing lights weren't working, checked and replaced fuse, not only did the reversing work but the warning light went out. hasn't come back on since. might be worth checking.
I'll look at that tomorrow, away from the van ATM. Cheers for the heads up!
 

·
Registered
Joined
·
274 Posts
Discussion Starter #15
Checked reversing lights.... working
New switch fitted (second hand from golf 4).....
Light still flashing!!
 

·
Registered
Joined
·
274 Posts
Discussion Starter #17
It was a pattern one so it didn't have the part number on it but it was similar dims but had the locking twist collar. Yeah reset plunger, worked fine as a brake light switch but same error code came back after changing switch. There must be something else wrong somewhere, unfortunately it looks like wiring..
 

·
Registered
Joined
·
30 Posts
I have got the same problem on my T5 - switch has been replaced 3 times. Brake lights have always worked. Bulbs replaced just in case, middle brake light changed but still have the error & the glow plug light flashes.

Did you get anywhere ?
 
1 - 20 of 66 Posts
Top