VW T4 Forum - VW T5 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All,

On a T4 Swb 1993 2.4 diesel I have a clanking sound while the engine is running. The most likely cause seems to be the Vacuum Pump and I am going to investigate further. I'm wondering if anyone has experience of the Just Kampers replacement as they are currently 20% off. So if that is the issue then I am tempted to make that purchase now.

Can anyone recommend these or an alternative.

Many thanks.

BTW I am new to these forums so just learning.

Nick
 

·
Premium Member
Joined
·
929 Posts
Is that the ones that are on back order and not in stock!

I've been looking too.

Mine is clacking/ ticking and needs doing again.
My last one was an ebay £80 special which lasted around 14 years which ain't bad going.

My lad has started working for a VW dealer so I'm going to see what deal he can get on them.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for reply. That's the one and I've investigated a bit further and definitely needs replacing.

Think ill order this weekend.

Nick
 

·
Premium Member
Joined
·
581 Posts
You may find that simply taking off the unit and draining the excess oil/give it a good clean will rid you of the clicking. Plenty of threads on here about it, also the seal is available from 123bearings.co.uk and the size I believe is 10x18x5.5 someone will correct me if I'm wrong :)
I'm going to do mine soon when I do all the other "take the undertray off" jobs!
Good luck and maybe save yerself a few bob!!
 
1 - 4 of 4 Posts
Top