VW T4 Forum - VW T5 Forum banner
1 - 10 of 10 Posts

·
Premium Member
Joined
·
871 Posts
Discussion Starter · #1 · (Edited)
Does anybody know where the door switch earth wire from the courtesy light attaches on a 2001 1.9td? My courtesy lights are not working at the moment.

With a multimeter I have checked the door switch and I'm getting an earth from that, but the black wire coming from behind the dash doesn't seem to be connected to the courtesy light. When I earth the brown and white wire coming down the a pillar, the lights work fine.

I hope this will make sense to somebody :confused:
 

·
Premium Member
Joined
·
3,715 Posts
cant recall the switch wire colour off hand,

how have you tested the door pin switch ? disassemble and clean all contacts, can you remove the female blade connector to the switch and earth that wire to get the lights on

have you checked its getting power at the light, with a probe?
 

·
Registered
Joined
·
10,601 Posts
The black wire is actually a brown/white sheathed in black and should connect to the fuse box. What year is your van?
 

·
Premium Member
Joined
·
871 Posts
Discussion Starter · #5 · (Edited)
The black wire is actually a brown/white sheathed in black and should connect to the fuse box. What year is your van?
It's a 2001 800 Special. The door contacts are fine, I replaced them before with new wire and spade connectors, I'm testing that by connecting the red multimeter probe to a 12v supply and the black one to the wire inside the van and pushing the door switch in and out shows it's working. Also, there is power at the light, switched works fine, it also works fine when I supply an earth to the wire in the A pillar. I was going to try and avoid pulling the whole fuse box out but looks like I might have to.
 

·
Registered
Joined
·
10,601 Posts
In the top left corner of the fuse box there is a connector marked TK m.l. This is where the brown/white (black sheathed) wire should connect to.
 

·
Premium Member
Joined
·
871 Posts
Discussion Starter · #7 ·
In the top left corner of the fuse box there is a connector marked TK m.l. This is where the brown/white (black sheathed) wire should connect to.
Thanks Martyn, that helped me to fix the problem. I found by connecting the door switch wire directly to TK m.l. it worked fine, so I've now just stuck with that and have removed the relay I had for delaying the interior light, which I think was ok, but does mean a lot of extra wiring to link remote locking/alarm and all so can live without. I also think this had something to do with the relay voltage levels I discussed with you as my leisure battery was very low this morning, but have been out for a drive since making the changes and the split relay has been working correctly in charging the leisure batteries T:

When I bought this T4 I was happy it didn't have too many electrics, I guess I need to keep it that way for a simpler life.
 

·
Registered
Joined
·
3 Posts
Could I ask an additional question,


My courtesy light works when switched to constant on,
when switched to door mode it works with the sliding door
but does not work when either of the front doors open.

I have just replaced the radio, is it all likely that the problem
originates there, or is it coincidence.

I have only just bought the van so cannot say for sure if
this problem is new.

Thanks
 
1 - 10 of 10 Posts
Top