VW T4 Forum - VW T5 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hi all,

We have a T4 camper, 02 plate. It's gone mad, and we need your superior knowledge to get it back to normal please!

The story so far:

Few weeks ago the engine cut out completely on the motorway. Doing about 70 mph at the time in the fast lane. Everything went, engine died. Pulled over to hard shoulder, then re-fired it up. Started fine.

The horn then died.

Although after that there have been no more problems - we drove from London to Brighton yesterday and it was fine.

However, this evening, it's all gone a bit wrong. The dashboard has gone crazy - the fuel gauge reads full when it isn't, speedometer has simply stopped working, temp guage goes all the way round then stops at the bottom, mileometer isn't reading anything - and there are just 'dashes' where numbers should be. Essentially everything on the dashboard has stopped working. Totally. There is also a sporadic alarm clock type noise coming from the dash.

The van itself seems to be running ok. Headlights etc are working.

I have the fear that this is going to be an expensive fix pre-xmas - that is if anyone knows what might be wrong with it?!

All help much appreciated. Thanks chaps.
 

·
Registered
Joined
·
573 Posts
Start by cleaning and retightening battery posts and ground straps. Also check in general is fuses relays etc are tight.
 

·
Registered
Joined
·
275 Posts
It's your earth, there are a couple to check but they will be the source of most electrical evils..

I had a similar issue whereby my fuel gauge would read whatever it liked, never accurate however...

It was the only gauge that was effected and I was convinced it was the fuel sender, turned out it was the earth, also fixed my horn too!

There is one earth that goes from the battery to the chassis under the battery tray and from there to the gearbox casing, take them off and check they are making a good contact.

That should sort out your electrical woes!
 

·
Premium Member
Joined
·
2,589 Posts
In my old VR6, the dashboard lit up like a christmas tree a few years ago and died. All gauges moved one last time and lay down. It was a faulty alternator.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
You are all wonderful. Thanks for the replies. We'll have a look at the battery posts / earth contacting where it should first. And if it's still not fixed check the alternator.

Will keep you all posted. Thanks ever so much again for your help!
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
Quick update....

The local garage plugged in the diagnostics and it came up with 25 error messages for the electrics.

As such, they sent us to VW as they said they couldn't help.

VW reckon it needs a whole new dash. The dude at the VW garage said it looked like someone had 'fiddled about with it'...(don't you just love VW....?)

We haven't fiddled wiuth anything. Never had any problems with the van since we bought it (second hand nearly 3 years ago). Seems weird that it wouldn't have broken before this if stuff have been installed incorrectly...?!! Who knows....

Anyway, the new dash, along with labour is the best part of £700...new dash is on order, but I just wanted to check with anyone who knows more than me about vans - does this seem like the most likely fix? Just cos a few of you guys mentioned earths and fuses...not new instrument clusters...

Thanks again chaps
 
1 - 6 of 6 Posts
Top