VW T4 Forum - VW T5 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #1
None of my switches on the doors work except the sliding door.

so tonight i took one apart to see if it could be repairs/bodged to work again.

Took passenger one out and it only has one wire connected to it. is that correct? I'm guessing it earths to van.

the lights would come on when part of the switch touched the metal of the van but the switch did nothing. Not sure how something so simple can break but it appears to be knackered.
 

·
Registered
Joined
·
8,736 Posts
Common fault with all door switches, earth the wire the lights should work
 

·
Registered
Joined
·
283 Posts
Discussion Starter #3
but it should only be one wire? Just making sure the other wire has not dropped off into the van
 

·
Registered
Joined
·
1,059 Posts
thank you. i may now relax and go buy new switches :)T:
On the other hand, cleaning up where the switch is mounted & putting some conductive grease in the hole where the screw goes & the old switch'll probably work. It's a simple switch. If it looks like it's in one piece, it probably works but the contacts or the mounting want cleaning up.

Bin there, done that. Now got pretty green interior lights.
 

·
Registered
Joined
·
283 Posts
Discussion Starter #7
Did as told, took them out. the connector was pretty worn out.

Cleaned it up but didn't work. cleaned it again but a bit more abrasive, still nothing. So i got some foil and twisted it up and wrapped it around the contact points (the little sharks teeth) and hey presto it worked. Taped it into place and now i have lights...plus I have a warning sound if i leave my lights on. Never knew i had that :)
 
1 - 7 of 7 Posts
Top