VW T4 Forum - VW T5 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,

I came back from holiday to a flat battery on the van, which was caused i believe by the hazard warning lights switching themselves on. I replaced the battery and found that the horn was sounding intermittantly whilst driving along, with other electrical equipment switching itself on randomly as well. I've been to the local garage who reset around 7 faults that were showing, but the hazard warning light continued to flash every now and again when the van was locked. Thursday the van was back in the garage after it stopped and would not start at services on the m6. they replaced the cam sensor and one other. I am now back to the hazard lights randomly operating whenever the van is locked.

Has anyone any ideas what is causing the fault. I have a sneaking suspicion that my local rural garage is just chasing the fault round in circles, has not found it and I'm paying for the mistakes.:confused:

Andy
 

·
Registered
Joined
·
237 Posts
Have you tried looking at the wiring loom under the drivers seat? There is a conection under the mat that gets wet and corrodes causing all sorts of random problems. Might be worth a look. It's one cable going into a fabric wrapped connection and the two wires coing out. there is plenty of info on this problem on the search.

chris.
 

·
Premium Member
Joined
·
1,293 Posts
Worth having a look at red and blue wire under drivers seat as mentioned, not faults I have had with it but doesn't mean it's not that and it's likely to give you problems In the future anyway, so make the connection good n see what happens. Could be a cheap/ free fix
Regards
Dan
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hi,

I've had the seat out today and checked the wiring loom as suggested and everything was bright and shiny. It's now all been waterproofed.

The bad news, is that the fault is still there and even with the ignition off, the hazard lights are switching themselves on and off and the horn sounding intermitantly. With the ignition on, the van is switching the heated rear window on and other controls and the horn and hazard lights continue to flash and sound at random intervals. The engine management light is not coming on with the ignition so I am now thoroughly puzzled.

Unless anyone else has any ideas or suggestions, its looking like a huge bill is coming in time for christmas from the auto electricians or vw.

Andy
 

·
Registered
Joined
·
10,602 Posts
Sounds like you need to get it to VW. It will be the cheaper option in the long run.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Re: electrical problems, help!! - answer

Hi,

Just to update you on this problem, I took the van to the auto electricians. Typically the horn sounded indicators flashed and the heated rear window switched on and off to within 2 miles of the place then stopped!

too many faults to mention were showing on the computer when it was plugged in. All were reset and the van was parked out in the cold and damp until today, when the hazard lights started to flash again all by themselves. The problem - faulty ignition electrics. They're fitting a new block behind the ignition switch, which should cure the problem.

Well at least I don't have to part ex the van before Christmas. I wonder if the threat was enough for it to reveal the problem lol.

Happy xmas all.

Andy
 

·
Registered
Joined
·
4 Posts
I have this exact same issue, happened last winter then stopped until around the same time this year all the faults came rushing back.

Now I'm wondering will it cure itself again or am I doomed?
 

·
Registered
Joined
·
1 Posts
HI there Guys, my first time posting. I have the same problem on my 2005 T5 Caravelle! My dashboard looks like a Christmas tree. Electrician checked the whole loom, except behind the dashboard. Please can someone tell me you know what the problem might be? I get "airbag fault" "Engine workshop" ABS lights and also my central locking (YES we did check under the driver seat) locks and unlocks randomly.

PLEASE HELP!!! I have spent almost 10,000 pounds in repairs already.
 

·
Registered
Joined
·
1 Posts
Got the dreaded hazard light fault on my '04 t5. Did anyone find the solution to this fault? Checked the wiring under the seat and behind the dash but still having the fault. Cheers
 
1 - 11 of 11 Posts
Top