VW T4 Forum - VW T5 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm having issues with both the oil light continuously flashing along with intermittent and sometimes constant buzzing noise. The latest problem which seems somewhat connected is the battery has been completely flat the last two times I've gone to start my van. I know a few questions have previously been asked on this but perhaps someone can help with what the specific problem is in my case? First thoughts are an issue with the alternator but not sure exactly... The buzzing happened initially at high revs but now it seems almost random after the van has been driving a little while and the other day it was as soon as I turned the engine in. Any help would be grately appreciated! Thanks Jonathan
 

·
Registered
Joined
·
430 Posts
Hello,

I'm afraid you're on the wrong forum here with a T25 - I'd go to club80-90 and have a search for the buzzer of doom (BOD). I'm going to guess you have a diesel but you've not provided any info at all - that engine and model info is pretty vital when asking for help.

On a T25 diesel (and some digifants) essentially you have 2 oil sensors - one low revs which breaks earth above 0.3bar, and another high revs which makes earth over 0.9bar (I think) - if this isn't earthing above 2000 rpm then you get the Buzzer you're talking about. First thing to do is check your oil pressure properly to eliminate an actual low oil pressure problem - if that's ok then you need to check your sensors and wiring, and then finally check the 14pin connector at the dash pod and then check the BOD wiring circuitry itself. You'll find a million posts on the subject on club80-90.
 
1 - 4 of 4 Posts
Top