VW T4 Forum - VW T5 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
373 Posts
Discussion Starter #1 (Edited)
horn not working no earth

Just fitted a steering wheel from an audi 80 fitted straight on no problem ive been having issues with my horn for a while so here foes

I have checked the fuses and have power checked the feed to the horn switch and have power now where i have a problem is there is no earth on the colum/wheel so nothing to switch why or how would my colum have no earth

If i earth out my colum and work the switch the horn works fine is there an earth wire anywhere that may be off cant see anything obvious

Any ideas??
 

·
Registered
Joined
·
646 Posts
I have an Audi 80 wheel on my van, will have a look this weekend and get some pics. I seem to remember having to use the slip ring from the old wheel on a plastic spacer.
 

·
Registered
Joined
·
646 Posts
Ok just had a look, this is my wheel (ignore the crappy halfrauds cover!).



As I said, I had to use the original T4 slip ring which I spaced out from the wheel so that the indicators would cancel. Spacers made from rings of plastic chopping board, white in the following pic



I then took the wire from the slip ring through a hole in the wheel and this connects to the spade terminal on the horn push



Hope this is of some help.
 

·
Registered
Joined
·
373 Posts
Discussion Starter #4
thanks for that,exact same steering wheel i just fitted great idea on the spacers for the canceling of the indicators T:

its all wired up fine and i have live feed to the steering wheel wires but the horn wont work as the other parts of the wheel that the contacts touch have no earth so cannot complete the circuit

i earthed my column with my power probe and then pressed the horn switch and it works perfectly i just cant work out why the column has no earth when its bolted parts of the body that are earthed :*:*
 

·
Registered
Joined
·
1,173 Posts
Chris - he probably has fixed by now but this may help if you have a similar fault?

See this problem a lot on mk1 golfs and caddys because there is a little earth cable down in the engine bay that connects from the steering column to the rack mounting brackets and earth into the bulkhead.

Not sure if there is the same setup on a T4???

Nope - it would seem to vary...

Just checked on a wiring diagram I have here for the early T4, the earth path is not via the column, it should leave the switch, go through a four pin connector on the column then via a brown wire back to the fuseboard and earths there.

Check the four pin connector and check either side of the connector for continuity - from one half of the connector to earth and from the other half of the connector up to the horn switch

For the later T4 it looks like it is earthed straight to the column but the wiring diagram doesn't mention the earth point location
 
1 - 6 of 6 Posts
Top