VW T4 Forum - VW T5 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi everyone,

Had my engine warning lamp (pic of a coil) start flashing on a journey and the engine went into safe mode and turbo stopped working. Has a mechanic run a diagnostic which came up with air leak. Particulate filter light came on before he had time to come back for another look. I managed to put that light out by driving between 2 - 2,500 revs for a while. Then got coil light start flashing again as well as the one that looks like an engine which refers to exhaust followed by particulate warning lamp back on. Mechanic came back and did a smoke test and found the leak was coming from the intercooler. He has fitted a new one but all 3 lights are still on and turbo not working. Is it just that he needs to clear the fault codes because the van doesn't know its been fixed? This time i can't get the diesel particulate filter light to go out by driving at constant 2 - 2,500 revs. When i managed this before i didn't have all the lights on. Before it was fixed the van smelt pretty bad when i stopped but that does seem to be fixed. Mechanic said he will come back and force regenerate. Does this sound like what needs to be done to end this run of nasty lights and worry? Its a 2006 2.5 T5 T28 SWB Thanks for any advice in advance.
 

·
Registered
Joined
·
11,439 Posts
Sounds like it needs a code read to see if anything new has appeared , clear codes if old and a regen wouldn't be a bad idea.

You'd be better driving it like you stole it to give it a clear out rather than pootling around ....but if you can't clear the lights yourself and it's gone into limp mode you'll have to wait for your man .
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for your reply mate. Cant clear it myself. Been up and down the local dual carriageway but its having none of it :(
 
1 - 3 of 3 Posts
Top