VW T4 Forum - VW T5 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey, just wondered if anyone else has come across this problem.

I upgraded my cab interior light to one with 3 lights (courtesy light and 2 push map lights) I see everyone on here who has done the same just says plug in and go, plugged it in and all lights will switch on and off perfectly, but when I set it to the mode which makes the lights come on when the doors are open all the lights just stay on all the time!!!!! It's doing my nut in having to switch them on and off manually.

Anyway hope someone has a fix for my problem :)
 

·
Valve Lifter
Joined
·
115 Posts
It's been happening on my T4 too.

The interior lights are earthed through all the door pin switches, (they are interconnected), so any switch where the 'pin' is not being sufficiently pushed in by a "closed" door to separate the contacts will leave your lights on.

For me it critically turned out that there was very slight fore and aft play on the sliding door, which together with a wide vertical gap at the front edge, meant that the pin switch was not quite engaged even when the door was closed and the van was stationary, so the interior lights stayed on.

By contrast, when I brake, the sliding door moves forward ever so slightly, thereby operating the pin switch and switching the interior lights off! Then I accelerate and the lights come on again. Hey Ho!

My plan is to repace all the sliding door rollers and hinge, which are now all over 20 years old, and then adjust the door to fit and function properly. I'm also fitting new seals, especially the top horizontal one, as I think they may have taken a 'set'.

Another culprit could be your rear door pin switch?

Jim24
T4 1999 2.4D
 

·
Registered
Joined
·
2 Posts
I have a 2014 T5.1. I was originally getting the door sensor on the dashboard come on saying my back door was open, checked the seals etc and couldnt see anything wrong. The sensor has now stopped but my interior light will still stay on when i lock the vehicle. Maybe try taking the fuse out to restart it?
 

·
Registered
Joined
·
242 Posts
You could try that, and / or disconnect the battery for 10 mins. (first make sure you have any necessary
radio code, check your owner's manual for battery procedure)
If the rear lid latch is not fully closed it would probably give that symptom, try actuating the latch with
a screwdriver or similar when the lid is open.
 

·
Premium Member
Joined
·
32 Posts
Any new ideas on this as my 2005 as started doing the same. Search suggests micro switch in drivers door can cause this fault. This is a mega ball ache to strip but if others have solved it this way I will start there. Mine did flash up tailgate open when drivers window is down goes out when up. That issue has now disappeared but left me with courtesy lights staying on.
 

·
Premium Member
Joined
·
32 Posts
Just an update if it helps others. I disconnected my battery for a long period whilst I swapped my T5 steering wheel for a Passat one. Involved switching the air bag plug over to fit. Randomly after a few hours of being disconnected and refitted fuse light now work as they should. Worth a try if anyone else has this problem.
 

·
Registered
Joined
·
242 Posts
Thanks for the update, it will definitely help someone if you come back with a positive outcome.
 
1 - 9 of 9 Posts
Top