VW T4 Forum - VW T5 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
We have a t4 camper with hook up. When hooked up it's supposed to charge the leisure battery, trickle charge the van battery, and provide 12v power for fridge, lights + radio.

It worked fine for about 2 summers but towards the end of last summer it started cutting out while hooked up - the voltage at the leisure battery terminals would drop from 13.8 down to 12 point something, indicating that it was no longer being charged. It would then run out :-(. I noticed that the fixes-all-IT-in-the-world trick of turning the charger off and on again sometimes woke it up and got us another half hour or hour of power, but it's still flakey.

It's a 16A max output charger, one of these: http://www.cbe.it/en/content/cb516

It lives in a cupboard where we stuff all the bedding, which is not ideal as it probably runs a little warm for its liking (although when it's been cutting out the cupboard has been empty). I've had a look inside and nothign looks obviously burnt out, but I can't tell much and am not an expert by any stretch of the imagination.

I've had the battery tested and it's apparently in top notch condition. It remains charged (it also gets charged by the alternator) and kicks out over 100A in a test.

So does it look like I should just replace the charger? And if so, has anyone got a recommendation? They all seem to be about £100 for a 20A output. If I had a fat ammeter I would try to test the current drawn by the radio, fridge and lights but I don't have anything that can measure that (I'm imagining it could be well over 10A when it's all on).
 

·
Registered
Joined
·
3,307 Posts
The man you need to speak to is Martin, at travelvolts.com, or message him on here, his username is 'upspex'.....!T:
 
1 - 3 of 3 Posts
Top