VW T4 Forum - VW T5 Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
416 Posts
Discussion Starter #1
Finally got my new van. 2002 swb 2.5tdi. Love it.
Changed wheels and fitted lowering springs today, now speedo not working:eek:
All other gauges working. Any ideas?
Also replaced rear pads now brake warning light staying on
Any way of turning it off?
 

·
Registered
Joined
·
416 Posts
Discussion Starter #2
Demented

aaaaah eerrrrrrrr :bhd :bhd :*:*:*:*
Cannot find damned pick up for speedo
Removed engine under cover, searched gearbox for distance unit..nope not there hsy:
Removed 4 wheels ...no no wires other than pad wear wires
Where the heck is it? is my 02 2.5 88bhp different to all the others?
Help before I go insane:confused:
 

·
Registered
Joined
·
643 Posts
Re: Demented

speedo pick up is on top at back of gearbox on 1.9 its a rectanglular plug 3 wires

check the fluid level in the brakes - it may need topping up.
 

·
Registered
Joined
·
416 Posts
Discussion Starter #4
Had another look this morning :bhd just can't find it
 

·
Registered
Joined
·
416 Posts
Discussion Starter #5
:bhd:bhd:*:bhd:bhd snookered with this one
 

·
Registered
Joined
·
70 Posts
If you open the bonnet and look down through the engine bay to the right of the turbo you should be able to see a silver flange type thing with poppers that covers the sensor. It is just out of reach from the top but once you know where it is you can get underneath, undo the poppers and unscrew the sensor. A new one is about 25 quid from VW
 

·
Registered
Joined
·
416 Posts
Discussion Starter #7
Cheers Simdog T:
I see it now. I already have the sensor, so I will fit it tomorrow evening.
 

·
Registered
Joined
·
416 Posts
Discussion Starter #8
Been a busy boy tonight, repaired ticking vacuum pump, repaired sliding door central locking.

Fitted damned distance sensor to gearbox but still no speedo :bhd:bhd:mad::(:*

This is driving me crazy. hsy:
VW dealer reckons it is dash fault and to replace dash instruments but at over 300 euros no way, not until I'm sure.

Can anyone through any light on this before I rack up 12 penalty points?

What else can I check???
 

·
Registered
Joined
·
11,100 Posts
i have a set of clocks,if you want to pay postage you are welcome to try them in and see if this cures your problem,if it does you can buy them if it doesnt you can send them back T:
 

·
Registered
Joined
·
416 Posts
Discussion Starter #10
Thank you T4VIRGIN, I really appreciate the offer.
I'm going to check the wiring to and from the speedo, and the alternator connections also, because my fuel gauge is fluctuating when driving also.

If that turns up a blank, I will pm you.

Again thank you. T:
 

·
Registered
Joined
·
416 Posts
Discussion Starter #11
:) now fixed. Found loose connections behind fuse boxJ:
Hopefully that's the end of that saga
 

·
Registered
Joined
·
416 Posts
Discussion Starter #13
I changed the rod inside the vacuum pump. Take off the pump and the rod just falls out.
There is also a tension spring on the pump. I loosened the retaining screw on the spring about one turn thinking that that would take up some slack in case there was some wear inside the pump. Refitted and no ticking H:H:
Fix it sooner rather than later, if you catch it early enough you will not need to replace the pump just the rod. I paid about 30 euros for the rod at a main stealer.
One problem fixed and now I have a new one......cut out today and will not start now.
Think it is the stopper solenoid on the fuel pump......:(
 

·
Premium Member
Joined
·
3,776 Posts
Had my fuse box out at the weekend and now my speedo isn't working :(

which connection was it in the fusebox

i'm sure if i just wingle them all back in it should sort it, the last time this happened was when i fitted a new clutch and it turned out to be the earth connection onto the box. T:
 
1 - 15 of 15 Posts
Top