VW T4 Forum - VW T5 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, we have a T4 1.9. We had the oil pressure light coming on, levels fine so we changed the oil and filter. No change so we took it to a mechanic and he said the pressure was fine but he didn't have time to do anything else. So we changed the oil pressure sensor. And now still no change. What can be the cause? Thank you for your help.
 

·
Registered
Joined
·
4 Posts
Hi, I have a smiliar problem, the oil pressure warning comes on when I drop below 2000 rpm but only sometimes. When i bought the van the guy told me he'd chsnged the clocks for the more up to date version as they were a different colour and also has a rev counter. I read on here that the 1.9 T4 (mine's a 1998) has 2 pressure switches and apparently if you change the clocks it can cause wiring feedback issues leading to the oil pressure warning coming on when you drop below 2000 rpm ( the window for the lower pressure sensor). I'm still looking into it and trying to get hold of a wiring diagram to help me so will let you know how I get on. One suggestion I'm lokking at is fitting a gauge on the dashboard and doing away with the warning buzzer.
Please let me know if you solve your problem first and how you did it.
 

·
Registered
Joined
·
4 Posts
Hi, an update on the last post. I changed the 2nd oil pressure swith, the grey one at the bottom of the engine by the oil filter head. It's a normally open switch, the opposite to the standard one and as mentioned before works at a higher pressure and only between 1800 and 2000 rpm ish (but only if your revs are in that range for more than a few seconds). This has solved the problem with the buzzer. Peace and quiet at last!!
 
1 - 4 of 4 Posts
Top