VW T4 Forum - VW T5 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
evening all....driving my 1.9 TD T4 home today - almost home when I hear a beep. the battery and oil pressure warning lights came on. towed the final 200 mts home. soon realised the auxilary belt had gone. but why the oil pressure warning? the oil pump can't be on that belt - can it!?
i checked the level and it was fine - the mileage is low (45,000 miles) so oil pump problem unlikely I hope?

can anyone explain please?

thanks
 

·
Registered
Joined
·
1,685 Posts
Oil light will come on as the system needs an rpm signal as well as oil pressure,don't ask me why or how,just be relieved that it does.
New belt and you'll be good to go T:T:T:
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
thats a relief! - thanks for the explaination - guess it gets rev signal from the alternator?

thanks again!
 

·
Registered
Joined
·
34 Posts
Discussion Starter #8
cheers all....fitted new aux belt. (£32 vw) both the oil pressure and battery warning lights have now gone off.

battery light - understandable but the oil pressure warning light coming on is crazy. It must measure the actual pressure via a sensor somewhere on the block or pump - you would have thought that a trigger to the warning light would come from this alone and not a stopped alternator also!
thanks for help
 

·
Registered
Joined
·
34 Posts
Discussion Starter #9
meant to say thanks penbryn for the link. just read it again - it does make more sense than it did at 1.30 this morning!
 
1 - 9 of 9 Posts
Top