VW T4 Forum - VW T5 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter · #1 ·
about 2 months ago my steering used to squeak when on full lock so i had the belt changed. it then worked fine, only a tiny squeak remained on real full lock... up until now..

its now juddering and squealing horribly when attempting to turn at slow speeds/stand still. driving along is fine until i make a tight turn left/right.

what could it be!?!? pump? belt..again? or something else? i've topped the fluid up so its not that.

any help would be much appreciated!!

Dan:(
 

·
Registered
Joined
·
126 Posts
Discussion Starter · #2 ·
someone has told me it could be air in the system or belt has come loose again??? possible or not??

cheers!
 

·
Registered
Joined
·
27 Posts
hi
just a few things to consider.try changing the fluid as if it is too old and thin then it wont function properly. it could be your pump on the way out or even a vavle within the pump. hope it helps. good luck.
 

·
Registered
Joined
·
126 Posts
Discussion Starter · #4 ·
thanks colin! sound like it is the pump cos the higher the revs the quieter the squeak and juddering is.
cheers mate
 

·
Registered
Joined
·
288 Posts
about 2 months ago my steering used to squeak when on full lock so i had the belt changed. it then worked fine, only a tiny squeak remained on real full lock... up until now..

its now juddering and squealing horribly when attempting to turn at slow speeds/stand still. driving along is fine until i make a tight turn left/right.

what could it be!?!? pump? belt..again? or something else? i've topped the fluid up so its not that.

any help would be much appreciated!!

Dan:(
Did you put the correect power steering fluid in? ie mineral??
 

·
Registered
Joined
·
126 Posts
Discussion Starter · #6 ·
yea i did, went to GSF and they do the number plate check thingy. van manual says it the right one. its still juddering. presuming its the pump. now then... to try and find a pump...?
 
1 - 6 of 6 Posts
Top