VW T4 Forum - VW T5 Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
2,554 Posts
Discussion Starter #1
Ive been having problems with my power steering. started just with a squealing on lock. The belts new, and tight and the fluids topped up and bled. And its red cos the cap is red.

But now it s squealing all the time and it seems to be juddering and resisting all the time. its making parking very difficult, not to mention embarassing.

Im starting to think its the pump thats gone. Wondering if its been damaged while it was off during the engine build. Maybe damaged, got something in it or maybe even run dry before i filled the fluid up.

Any thoughts?

Cheers, Nick
 

·
Registered
Joined
·
8 Posts
hi
i have exacly the same with my power steering.i was told to try power steering additive conditioner first,may prolong the pump life before splashing out on expensive pump.i drained and renewed fluid with blistein then i brought wynns conditioner stuff today but i know lucas do some and slick 50.just don,t know which ones best with green fluid??any advice for me and matey
 

·
Premium Member
Joined
·
2,554 Posts
Discussion Starter #4
hi
i have exacly the same with my power steering.i was told to try power steering additive conditioner first,may prolong the pump life before splashing out on expensive pump.i drained and renewed fluid with blistein then i brought wynns conditioner stuff today but i know lucas do some and slick 50.just don,t know which ones best with green fluid??any advice for me and matey
I'll be honest I dont know much about the additives. I'd guess that mine is beyond that. It sometimes feels like there's no power steering at all.
 

·
Registered
Joined
·
8,736 Posts
1 - 6 of 6 Posts
Top