VW T4 Forum - VW T5 Forum banner

1 - 16 of 16 Posts

·
Premium Member
Joined
·
85 Posts
Discussion Starter #1
I have a Kenwood head unit that every time I turn the ignition off loses its preset stations. Even tried swopping it with a Sony unit that I have lying around and that does the same!
Anybody got any ideas? I am not good with electrics so please make any advice as simple as possible.
Thanks.
 

·
Want Electrics? Go Wildebus!
Joined
·
8,171 Posts
I have a Kenwood head unit that every time I turn the ignition off loses its preset stations. Even tried swopping it with a Sony unit that I have lying around and that does the same!
Anybody got any ideas? I am not good with electrics so please make any advice as simple as possible.
Thanks.
You need to swap the yellow and red leads around in the radio loom (these will be on pluggable connectors specifically to be able to do this).
VW wire them in reverse to the default.

Once you do that, the problem will be fixed T:
 

·
Registered
Joined
·
968 Posts
Thank you, Thank you, Thank you for this reply.

I thought I would just have to live with my stereo being like this after I'd paid quite a bit for a decent Sony DAB stereo, swapped the red and yellow cables last night and it now works a dream!
 

·
Registered
Joined
·
968 Posts
Quick question, if I wanted to wire in a dashcam that only came on with the ignition (the dashcam wire has one red cable and one black) would it be the red wire or the yellow for the red dashcam wire and where would I wire the black dashcam wire to?

thanks.
 

·
Registered
Joined
·
602 Posts
Quick question, if I wanted to wire in a dashcam that only came on with the ignition (the dashcam wire has one red cable and one black) would it be the red wire or the yellow for the red dashcam wire and where would I wire the black dashcam wire to?

thanks.
it needs to come from an ignition live source. plenty in fusebox
 

·
Want Electrics? Go Wildebus!
Joined
·
8,171 Posts
Quick question, if I wanted to wire in a dashcam that only came on with the ignition (the dashcam wire has one red cable and one black) would it be the red wire or the yellow for the red dashcam wire and where would I wire the black dashcam wire to?

thanks.
the Red wire on the RADIO LOOM is the ignition, and the yellow wire on the RADIO LOOM is the permanent +12V, and finally the Black wire on the RADIO LOOM is the ground, which is probably what the Black dashcam wire will be as well.
so if you wanted to use the radio loom to control the dashcam, you could use those wires, or follow the wires to the other side of the ISO plugs to get to the VW LOOM and see what colours they are T:
 

·
Premium Member
Joined
·
85 Posts
Discussion Starter #8
Thanks fo the replies and info. I am sure it will solve my problem. I have been told ( off the forum) that on my t4 (1999/2000 year) the wires may be red and brown. Can anyone confirm ordismiss this?
Only problem now is getting the bl#@d¥ thing out! Its well stuck in at the moment! lol.
 

·
Want Electrics? Go Wildebus!
Joined
·
8,171 Posts
Thanks fo the replies and info. I am sure it will solve my problem. I have been told ( off the forum) that on my t4 (1999/2000 year) the wires may be red and brown. Can anyone confirm ordismiss this?
Only problem now is getting the bl#@d¥ thing out! Its well stuck in at the moment! lol.
doesn't matter what the vehicle loom colours are (they are very unlikely to match radio makers colours) - to find out, just follow the red and yellow wires from the radio loom T:

(be greatful you don't try and follow Toyota radio colours .... around 30+ wires, and every single one is white with a black stripe!)
 

·
Full of Cr*p....
Joined
·
9,149 Posts
Thanks fo the replies and info. I am sure it will solve my problem. I have been told ( off the forum) that on my t4 (1999/2000 year) the wires may be red and brown. Can anyone confirm ordismiss this?
Only problem now is getting the bl#@d¥ thing out! Its well stuck in at the moment! lol.
BROWN is the ground/negative!
Leave that one alone!

If it's a new unit, it should have come with 2 "tools" to remove it.
Slide into the sides, lock, and pull.
 

·
Premium Member
Joined
·
397 Posts
Stop what youre doing immediately. Go to a professional who does know what theyre doing. Pay them to do it.
And why would he want to do that for, he may want the buzz from researching and doing the job himself.
Immense self satisfaction.
 

·
Registered
Joined
·
3,877 Posts
I say that because people seem to have to be labouring the point about insulation colours, when in fact wiring like this should always be conducted based on pinouts and circuit diagrams, then tested to verify, insulation may be pertinent for colour codes, but should never be followed purely and blindly by colours without using the proper methods first, you dont know if someones changed it in the past for a start.

No it isnt rocket science, it is however the realm of an automotive electrician.

Ive seen people get a buzz from electrical circuits, sometimes they dont have to go to hospital.

Granted its only 12V DC, but get it wrong and at best you might just wreck your expensive electronic whatever, worst case you might manage to start a fire.
 

·
Want Electrics? Go Wildebus!
Joined
·
8,171 Posts
Thanks fo the replies and info. I am sure it will solve my problem. I have been told ( off the forum) that on my t4 (1999/2000 year) the wires may be red and brown. Can anyone confirm ordismiss this?
Only problem now is getting the bl#@d¥ thing out! Its well stuck in at the moment! lol.
Bit of self-promotion .... If you get one of my radio drive/camping selector kits, I can add a extra bit of wiring to let you connect up the dashcam without any worries T:
 

·
Registered
Joined
·
1 Posts
Hi every one, first time posting. Can anyone help me out with a radio problem. the radio is wired correctly. I can switch radio on from accessory position, but when I start the van the radio switches off and pre-set stations are lost. I have noticed that when switching ignition off the radio will light for a brief second. I am beginning to suspect the ignition switch. Thanks in advance for any help or suggestions.
 
1 - 16 of 16 Posts
Top