VW T4 Forum - VW T5 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Afternoon All,

Six months ago I purchased a 2015 StartLine from VW in Swansea. It came with extras including Bluetooth for the phone system - an essential for me.

The radio in the van was a simply RCD210 - not the best, but good enough until I could afford something bigger and better.

Everything has been good but I was offered an RCD310 so I bought it. I was told it had Bluetooth audio (which I had on my old Ford Kuga and missed). I took it home, fitted it, entered the code. It was working - but I cannot get the Bluetooth audio to work.

I've tried everything I've read on the web but feel I am missing something. Under the radio settings I have turned Bluetooth Audio on (a one time setting I'm told) - nothing.

My van Bluetooth works with no fitted radio so I am assuming it was dealer fitted. Can I therefore assume it is interfering with the RCD310?

I'm tearing my hair out whilst researching. I'm discussing it with someone on a Facebook group also but am bringing it here as well. If I cannot sort it then the radio will go back - yet I wonder whether other radios would be affected too.

Any advice would be appreciated,

Gareth
 

·
Special Rapporteur
Joined
·
8,750 Posts
My van Bluetooth works with no fitted radio so I am assuming it was dealer fitted. Can I therefore assume it is interfering with the RCD310?
That seems very unlikely - Bluetooth is designed to cope with lots of different devices all operating in the area at the same time.

I guess you just can't see the RCD310 when you try to pair a device with it? I don't know about the RCD310 but some Bluetooth devices are only able to pair with one device at a time, so if it's been used with BT before it may already have the previous owner's BT device in its memory, and that needs to be deleted before you can pair another?
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
That seems very unlikely - Bluetooth is designed to cope with lots of different devices all operating in the area at the same time.

I guess you just can't see the RCD310 when you try to pair a device with it? I don't know about the RCD310 but some Bluetooth devices are only able to pair with one device at a time, so if it's been used with BT before it may already have the previous owner's BT device in its memory, and that needs to be deleted before you can pair another?
I'm not sure about that. It isn't even showing a second device on my phone. It just shows VW Phone - if the RCD310 was broadcasting then it would show a second VW Phone too. That's how it used to work in my two Fords - we had a Kuga and a Fiesta and it showed both of them on one phone when they were both parked together.

Gareth
 

·
Registered
Joined
·
127 Posts
I think some 310s come with BT and some don't. The one in mine sadly didn't so I upgraded to a 510 and a separate BT module. Bigger screen too T:

ISTR the radio goes into pairing mode for a minute or so after the ignition comes on, so if you plumb it in, turn the ignition on and don't see it on your phone then it's not got it fitted. Not sure there's any VAGCOM settings you would need to do (like I did to enable my BT module).

HTH.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #5
I think some 310s come with BT and some don't. The one in mine sadly didn't so I upgraded to a 510 and a separate BT module. Bigger screen too T:

ISTR the radio goes into pairing mode for a minute or so after the ignition comes on, so if you plumb it in, turn the ignition on and don't see it on your phone then it's not got it fitted. Not sure there's any VAGCOM settings you would need to do (like I did to enable my BT module).

HTH.
Thanks @huey for getting in touch. One would assume that if it had the Bluetooth Audio setting that it would work. I've since found out, since my original post, that the Bluetooth is factory fitted and of VW make. So one should assume it would just plug and play.

I'm taking it back tomorrow to see if they have another one.

Thanks everyone. I'll report back what I find.

GJE
 

·
Registered
Joined
·
29 Posts
Discussion Starter #6
Thanks @huey for getting in touch. One would assume that if it had the Bluetooth Audio setting that it would work. I've since found out, since my original post, that the Bluetooth is factory fitted and of VW make. So one should assume it would just plug and play.

I'm taking it back tomorrow to see if they have another one.

Thanks everyone. I'll report back what I find.

GJE
Well - to bring this to a close....

I phoned VW yesterday who said nothing could be done so I went in to the showroom today where I was told (once they checked out the back) that it could be done - the radio would need re-coding to tell it there was a bluetooth module (or vice versa).

They then wanted £35+VAT to do it. - not a chance.

Now I work in Comp Sci where most things are plug and play so is it unreasonable to expect a VW stereo to work with a VW bluetooth module - out of the box. IT DOESNT and I'm not paying that.

Luckily the good guys who sold me the radio are going to sort it on Tuesday for me. I won't mention who they are - but seems they are a good company and I will definitely be taking some conversion business their way pretty soon

Cheers everyone for advice,

Gareth
 

·
Registered
Joined
·
5 Posts
Hi Gareth,

How did you get on with your RCD310 and Bluetooth audio streaming? I am having a very similar problem in that I have the RCD310 and the Bluetooth module 9w7. I can use the phone and see the phone book. I can see the option to enable Bluetooth, I switch it on but I am still unable to stream any music. Even if I am playing music on my iPhone 6 when I change to media.

If anyone else can help I'd really appreciate it.

Many thanks.

Thanks @huey for getting in touch. One would assume that if it had the Bluetooth Audio setting that it would work. I've since found out, since my original post, that the Bluetooth is factory fitted and of VW make. So one should assume it would just plug and play.

I'm taking it back tomorrow to see if they have another one.

Thanks everyone. I'll report back what I find.

GJE
Well - to bring this to a close....

I phoned VW yesterday who said nothing could be done so I went in to the showroom today where I was told (once they checked out the back) that it could be done - the radio would need re-coding to tell it there was a bluetooth module (or vice versa).

They then wanted £35+VAT to do it. - not a chance.

Now I work in Comp Sci where most things are plug and play so is it unreasonable to expect a VW stereo to work with a VW bluetooth module - out of the box. IT DOESNT and I'm not paying that.

Luckily the good guys who sold me the radio are going to sort it on Tuesday for me. I won't mention who they are - but seems they are a good company and I will definitely be taking some conversion business their way pretty soon

Cheers everyone for advice,

Gareth
 

·
Registered
Joined
·
38 Posts
Same issue. Anyone get this resolved?

My bluetooth WAS working, but then disappeared from the the MEDIA menu on the RCD310.

The MFD still connects to bluetooth fine, just not the radio.
 

·
Registered
Joined
·
89 Posts
Same issue. Anyone get this resolved?

My bluetooth WAS working, but then disappeared from the the MEDIA menu on the RCD310.

The MFD still connects to bluetooth fine, just not the radio.
I am having this same issue. Sometimes it works, sometimes it doesn’t, sometimes it doesn’t even show the Bluetooth option. How’re the phone is shown as connected, including media player in the MFD.
 
1 - 10 of 10 Posts
Top