VW T4 Forum - VW T5 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hi

Ive just retrofitted a RNS510 DAB head unit, and the chap I bought it from locally helped me code it to the best of his abilities.

Since then all looks ok, but I now have random ESC fault light coming on, which I think might be down to the ESC button being disconnected during install, but it comes on randomly, you can drive for ages and it comes on for a few minutes and goes back off again, never seen the fault light before, so must of been caused since saturday.

I also remember seeing him view the coding page of highline display, which I think he left it on, as there was no lowline/midline dash option. He removed dynaudio setting, and configured the 2 speaker option, but because I didn't do it myself, I cant vouch for what he did was ultimately correct?

I need to put the RCD210 temporarily back as I left a cd in the slot, I'm not sure if doing this will hinder any current coding?

He also noticed the actual mileage was 4 miles different from the odometer and what the ECU thinks the mileage is, probably down to us fitting 18 inch sportline wheels last year, as an upgrade from the standard steelies, this will need looking at also.

I dont have vagcom myself yet, but its next on my shopping list.

I want to fit a MFSW and upgrade the dash to midline, with the necessary wires also, again I'd need advice on this?

Would anyone be willing to help me, who has a knowledge of vagcom, to put it all right please?

Anyone near Cheltenham who can help please?

Cheers in advance

Dean
 

·
Special Rapporteur
Joined
·
10,157 Posts
Since then all looks ok, but I now have random ESC fault light coming on, which I think might be down to the ESC button being disconnected during install, but it comes on randomly, you can drive for ages and it comes on for a few minutes and goes back off again, never seen the fault light before, so must of been caused since saturday.
I would say that it's very unlikely that this is anything to do with the headunit install or coding. If the connection to the ESC switch fails while the ignition is on then you should get an error light that stays on until it's reset. It's more likely to be a problem somewhere in the brake system. Reading the diagnostic codes should give you more information about where the fault is likely to be.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
Theres never been a problem with that error light appearing since stereo install.

It could be down to the fascia being removed when installing, and the switch being disconnected again when refitting the air vent fascia?

Dean
 
1 - 5 of 5 Posts
Top