VW T4 Forum - VW T5 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
Driving out the gate and my T4 died, Started back up and starts for 2 seconds and dies again.

Hooked up the Vag com and got errors
P1570 Contr.Module Locked
P1612 Electronic Control Module Incorrect Coding

Tried the 109 relay in my friends van and it works perfect

Everything looks alright tried all 3 keys also tired unhooking battery off for 3 hours still no go

Crank sensor is reading

I'm stuck looks like it could be a main dealer job :(

Van is a 2001 T4 2.5Tdi Not chipped as far as my known
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #3 ·
I live in Ireland but it was imported from the Uk and is black swb

I checked Voltage from battery and its 12v and fuses 15 16 and 18


I was looking in the Ecu and notice that it has been opened before or else black tape wrapped around it but 2 wires are cut or broken. Brown and a White and gray I joined the brown as it was easy but can't see the other end of the white and gray. Is this a mod or anything? Just before I go looking for the white and gray wire.
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #4 ·
PS I was driving it across the yard when it cut out

Bad pics but it is at night with a phone camera. I just joined the brown and tried it with no go. They are very cleanly broke it is a bit like a mod or something.



 

·
Registered
Joined
·
92 Posts
Discussion Starter · #6 ·
Can anybody tell me what the skc code looks like. On my spare key I got a 9 digit code and a 7 digit code on genuine key set
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #8 ·
I fixed the brown but the white seems to go to nothing

I think I'll have to send it into the be dealer PITA cause they are not open again till the new year
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #9 ·
Have got up another error code p1640 :( This van is my daily drive so I'm
Kinda stuck

I was never told if the van was chipped so I'm stuck there. My friend has a Ecu from a 2.5tdi do they swap out or
Need resetting?

I work fixing computers soldering ect, would it be a bit adventurous opening up the ecu in work to check it??


18048/P1640/005696 - Internal Control Module: EEPROM Error

Possible Causes
Engine Control Module modified (e.g. Chip Tuning)
Engine Control Module faulty
Possible Solutions
Contact your Tuner;)
Replace Engine Control Module
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #10 ·
I'll keep updating my finds in case anybody else has this problem


I called a Tuner and he says it will run in Limp mode or run with a chip gone bad. He can bypass the immobiliser but thats last resort he says. Told me the P1640 can mean a fault upto the Ecu meaning Fuse,Wire or Immobiliser issue but seen as 3 keys don't work he thinks it could be a wire or fuse. Guess I'm gonna have to find out what that white wire goes too but really looks like nothing.

Damn should have kept my 2.4 It was electric free
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #11 ·
Next update :confused:


Took the top cover off the Ecu to find out what the wires go to, I don't think this is the problem but worth a shot

As you can see the brown wire I fixed that, The gray and white is cut but leading off into another hole in the dash in Pic 2. In Pic 3 you can see the gray wire is unplug? Any Idea or wire reference diagram anybody? I also Noticed in Pic 4 a red wire coming up by the foot area? Looks to be going to the clocks anybody else 2.5 have this?







 

·
Registered
Joined
·
92 Posts
Discussion Starter · #12 ·
For what its worth I'll update


Checked all the cables and everything seems okay, Looks like the immobiliser has been replaced before 2008 marked on the box.


So I'm bringing the Ecu to a tuner tomo and he is disabling the Immo cheaper and less hassle than the Vw stealers to put it on the ramp.
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #13 ·
Van Back on the road, Got the Immo Disabled by the Ecu tuner delight! Back to better Mpg compared to driving my dads vito even nicer to drive too :)


Only problem now is I have a flashing glow plug light :bhd
 
1 - 13 of 13 Posts
Top