VW T4 Forum - VW T5 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Guys, need some help with this.
I have had the cambelt break on my vw transporter 888 special 2.4 diesel, and had to have the head refurbished by my local garage. Damage wasn't major as I was only doing 15 mph when it happened. I have now collected it and although it's running ok, a bit smoky when cold, it looks like the top half of the engine is older and dirtier than my original engine! Can anyone tell me whether that could be possible as I have had my van from new and when it went in for repair it was like new. What I need is an image of the original engine, if anyone can help its a 2003 model and then I can compare to mine. Wish I had taken a pic before it went in cause they are insisting it's mine but i'm convinced it's not!!!
Cheers Bill
 

·
Registered
Joined
·
1,144 Posts
It almost sounds like a changeover head from an engine reconditioners. The other thing it could be if it has been put in a chemical bath to clean out the water galleries & oil varnish. To find out you will need to ask them.
 

·
Registered
Joined
·
37 Posts
*<:)> hi what makes you think its not yours?*<:)>
It almost sounds like a changeover head from an engine reconditioners. The other thing it could be if it has been put in a chemical bath to clean out the water galleries & oil varnish. To find out you will need to ask them.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
The reason i know the parts are not mine is because they all look older, even some of the hoses are frayed, the cam belt cover plate has some wording on it but its worn out!, the alternator suddenly looks 10 years older! And the layout looks different,i need to see a photo of the engine compartment on a 2003 model to compare.
Wish i had taken a photo of my engine before it went in for repair.
 
1 - 4 of 4 Posts
Top