VW T4 Forum - VW T5 Forum banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
315 Posts
Discussion Starter #1
Hi all,

Recently I've been having a small problem with my 2.5TDI T4 auto (03) which I'll describe as best I can in the hope someone can help T:

As with most automatics (I think), in order to select a gear once the engine is started, you need to depress the brake pedal. On doing so, you can then press the button on the gear selector and choose a gear.

On my van however, this process has started to become a little problematic. I'll start the engine, press the brake pedal and the button on the selector will not engage. It will eventually, but I have to go through a process of pressing the brake pedal a few times or waiting for a bit and I'll finally hear the click indicating I can select a gear.

I can't say for sure what combination of waiting/pressing makes this happen and there are no specific conditions (like cold weather) where this happens more. Sometimes it works as normal.

I'm not sure if it's related or as per design, but in order to select a gear other than drive, reverse or neutral, I have to press the button on the gear selector in about half way. Pressing it in all the way won't allow me to change.

Any help or advice would be much appreciated

Cheers and Happy New Year.

T :ILU:
 

·
Premium Member
Joined
·
315 Posts
Discussion Starter #3
Thanks mate - will take a look and see if I can see what switches are down there. Found a switch on eBay for 9 quid so hopefully that's it!
 

·
Registered
Joined
·
334 Posts
i select a gear that is not PRND, i.e. 3,2 or 1 you do not push the button in at all and just knock it from D into the 3, 2 or 1 and back again
 

·
Registered
Joined
·
49 Posts
I dont believe it! I have the exact same problem, was just about to put up a post about it. It happened last night, just couldnt get it out of park! (button would not go in on stick)lots of random fiddling got it going again. Can you let me know if the brake switch fixes it and if so where it is?
When we did get home i noticed the glow plug light was flashing too, could this be why? Thanks for any help. Steve
 

·
Premium Member
Joined
·
315 Posts
Discussion Starter #7
i select a gear that is not PRND, i.e. 3,2 or 1 you do not push the button in at all and just knock it from D into the 3, 2 or 1 and back again
Cheers fella - feel like a bit of a dullard now. That worked I:

Although it does miss 3 and jump to 2 unless I'm really careful. 1 & 2 are fine. Sound right?

T
 

·
Registered
Joined
·
49 Posts
Have just had a fiddle with the brake switch on the pedal, its deffinately the switch causing my problem. I can hear a solinoid clicking in the gelector housing when Tap the switch and it sticks sometimes. I also got the fault code from my code reader as the glowplug indicator was flashing.
"16955" which is brake circuit /switch fault!! T:
So have ordered a new one from GSF at £6.50. cheers steve
 

·
Registered
Joined
·
49 Posts
Thanks for the info, had a go at fixing the switch myself, as the link you posted says,its easy and it now works perfectly everytime! Steve
 
1 - 9 of 9 Posts
Top